Skrevet av Emne: Har atter et zebra-batteri sagt takk for seg?  (Lest 343 ganger)

Vidar_S

  • Jr. Member
  • **
  • Innlegg: 40
    • Vis profil
Har atter et zebra-batteri sagt takk for seg?
« på: mandag 05. november 2018, klokken 20:10 »
Etter å ha gått nesten problemfritt i et knapt år ("bare" byttet bremser/calipere foran og vakuumpumpe til bremseservo) kan det se ut til at min Think (Zebra) igjen synger på siste verset. Den tar plutselig ikke lading lengre. Lys for tilkoblet strøm lyser fast og "ladelyset" blinker i noen minutter før det slår seg av, altså ganske likt det som beskrives her: http://elbilwiki.no/index.php/Think:Hva_er_feil_n%C3%A5r_._._. :

Sitat
Ladelys blinker i noen minutter og så stopper

Lav spenning i batteripakken. Isolasjonsfeil.
Vent noen minutter og forsøk på nytt. 

Jeg har for orders skyld forsøkt å vente både noen minutter og noen timer uten at det gjør noen forskjell. Inntil videre fungerer bilen ellers som den skal. Kjørte til og fra jobb i dag og ingen varsellys eller lignende, men det er nå rundt 50% igjen på batteriet så kun snakk om tid før batteriet går tomt.

Opplevde noenlunde det samme her i fjor høst etter at jeg kom tilbake fra ferie, men da var batteriet allerede tomt og blinking på ladelys varte lengre ettersom batteriet skulle varmes opp før den fant ut den ikke ville lade. Den gang ble redningen å bytte ut Zebra-batteriet siden jeg fant en Think som hadde batteri, men ellers ikke var helt på topp, men det er nok ingen mulighet denne gangen. Det store spørsmålet er da om noen har tips til hva som _kan_ være galt her ut over at batteriet har tatt kvelden. Om det er noen måte å få testet hva som er galt uten å måtte frakte bilen 4-500 km til elbilmek hadde jo det også vært hyggelig :)

Kjøpte meg en CANalyzer fra PRensel her på forumet ved forrige korsvei (da første batteri nektet samarbeide) og denne viser følgende log-output:

0x303: voltageMaxCharge: 369.00 currentMaxCharge: 0.00 VehicleChargeEnable: 0 regenBrakingEnable: 0 dischargeEnable: 0 fastchargeEnable: 0 DCDC enable: 0 AC present: 1 Battery released: 0 reducedNumberOfBatt: 1 EPO: 0 Crash: 0 Fan_status: 0 SOC102: 0 HV iso test: 0 Waiting_temp_err: 0

..sånn om noen klarer tyde mer ut av de dataene enn jeg gjør.

Alt av tips mottas med takk


Vidar

Orla Pedersen

  • Jr. Member
  • **
  • Innlegg: 64
    • Vis profil
Sv: Har atter et zebra-batteri sagt takk for seg?
« Svar #1 på: tirsdag 06. november 2018, klokken 11:57 »
Hvad står der i 0x304: sys_highesterrcat?
0x305: sys_extIsoError, sys_intIsoError og sys_BMI_State?
0x310 og 0x311 er også interessante.
Mvh
Orla Pedersen

Vidar_S

  • Jr. Member
  • **
  • Innlegg: 40
    • Vis profil
Sv: Har atter et zebra-batteri sagt takk for seg?
« Svar #2 på: tirsdag 06. november 2018, klokken 17:51 »
Hvad står der i 0x304: sys_highesterrcat?
0x305: sys_extIsoError, sys_intIsoError og sys_BMI_State?
0x310 og 0x311 er også interessante.

Takk for svar!

Her er det jeg får ut når bilen startes opp:

0x304: voltageMaxGenerator: 3844 highestErrCat: 0 EOC: 0 Reach_EOC: 0 Waiting_OK_Temp: 0 Too_Much_FC: 0 ACheaterRelayStatus: 0 ACheaterSwitchStatus: 0 T1: 265.30degC T2: 264.20degC

0x305: Charger_PWM: 0.00 extIsoErr: 0 intIsoErr: 0 BMI_State: 1 (Discharge) Battery_Type: 0 (Z36) Charge_Overcurrent: 0 Charge_OverVoltage: 0 No_Charge_Current: 0 OCV_Meas_In_Prog: 0 BatteryChargeEN: 0 Nr_Of_Failed_Cells: 0 Waiting_OK_Temp: 0 thermalISoError: 0 Zebra_TempError: 0 BMITempError: 0

0x310: RequestData: 1 BroadcastMode: 0 ChangeModeRequest: 0 Charger_Status: 0 TIM_Status: 1 DCDC_Status: 1 PCU_Fault: 0

0x311: BatteryChargeRequest: 0 VehicleChargeRequest: 0 FastChargeRequest: 0 AvailableMainsCurrent: 0.00

Ved forsøk på lading:
0x304: voltageMaxGenerator: 0 highestErrCat: 0 EOC: 0 Reach_EOC: 0 Waiting_OK_Temp: 0 Too_Much_FC: 0 ACheaterRelayStatus: 0 ACheaterSwitchStatus: 0 T1: 264.30degC T2: 263.90degC

0x305 veksler mellom
 Charger_PWM: 0.00 extIsoErr: 0 intIsoErr: 0 BMI_State: 3 (Charging) Battery_Type: 0 (Z36) Charge_Overcurrent: 0 Charge_OverVoltage: 0 No_Charge_Current: 0 OCV_Meas_In_Prog: 0 BatteryChargeEN: 1 Nr_Of_Failed_Cells: 0 Waiting_OK_Temp: 0 thermalISoError: 0 Zebra_TempError: 0 BMITempError: 0
og
 Charger_PWM: 0.00 extIsoErr: 0 intIsoErr: 0 BMI_State: 0 (Park) Battery_Type: 0 (Z36) Charge_Overcurrent: 0 Charge_OverVoltage: 0 No_Charge_Current: 0 OCV_Meas_In_Prog: 0 BatteryChargeEN: 1 Nr_Of_Failed_Cells: 0 Waiting_OK_Temp: 0 thermalISoError: 0 Zebra_TempError: 0 BMITempError: 0

0x311 veksler mellom
 BatteryChargeRequest: 1 VehicleChargeRequest: 0 FastChargeRequest: 0 AvailableMainsCurrent: 9.40
og
 BatteryChargeRequest: 0 VehicleChargeRequest: 0 FastChargeRequest: 0 AvailableMainsCurrent: 9.40

« Siste redigering: tirsdag 06. november 2018, klokken 20:32 av Vidar_S »

Vidar_S

  • Jr. Member
  • **
  • Innlegg: 40
    • Vis profil
Sv: Har atter et zebra-batteri sagt takk for seg?
« Svar #3 på: tirsdag 06. november 2018, klokken 20:27 »
Lot bilen stå med ladekabel i og nå (etter at ladelyset har slutter å blinke) får jeg følgende output fra CANalyzer:

0x311: BatteryChargeRequest: 1 VehicleChargeRequest: 0 FastChargeRequest: 0 AvailableMainsCurrent: 9.40

0x263: Mains_current: 0.00A Mains_voltage: 0V SLI_Amb_Temp: 6.00degC SLI_Voltage: 14.00V Vehicle_Speed: 0.00kmh

0x302: sys_errGeneral: 1 isoError: 0 voltageMinDischarge: 369.00 currentMaxDischarge: 0.00

0x303: voltageMaxCharge: 369.00 currentMaxCharge: 0.00 VehicleChargeEnable: 0 regenBrakingEnable: 0 dischargeEnable: 0 fastchargeEnable: 0 DCDC enable: 0 AC present: 1 Battery released: 0 reducedNumberOfBatt: 1 EPO: 0 Crash: 0 Fan_status: 0 SOC102: 0 HV iso test: 0 Waiting_temp_err: 0

0x304: voltageMaxGenerator: 0 highestErrCat: 3 EOC: 0 Reach_EOC: 0 Waiting_OK_Temp: 0 Too_Much_FC: 0 ACheaterRelayStatus: 0 ACheaterSwitchStatus: 0 T1: 261.60degC T2: 263.60degC

0x264: PASEnable : 0 PilotSignalPresent: 1 OverTempIndication: 0 ElectricHzIndication: 0 MILIndication: 0 LowSOCIndication: 0 AuxBatLowIndication: 0 PowerLimitIndication: 0 BrakeWarningIndication: 0 ABSWarningIndication: 0 EconomyIndication: 0 OnPlugIndication: 0 ChargingIndication: 0 DriveEnableIndication: 0 ParkIndication: 0 ReverseIndication: 0 NeutralIndication: 0 DriveIndication: 0 PowerTrainGeneration: 0 PCUESPSoftware: 0 GearPosition: 0 PCUPTCReady: 0 ESPIndication: 0

0x305: Charger_PWM: 0.00 extIsoErr: 0 intIsoErr: 0 BMI_State: 15 (FAULT) Battery_Type: 0 (Z36) Charge_Overcurrent: 0 Charge_OverVoltage: 0 No_Charge_Current: 0 OCV_Meas_In_Prog: 0 BatteryChargeEN: 0 Nr_Of_Failed_Cells: 0 Waiting_OK_Temp: 0 thermalISoError: 0 Zebra_TempError: 0 BMITempError: 0

0x301: current: 0.00A voltage: 368.10V dod: 52.80% tempMean: 262.60degC

Vidar_S

  • Jr. Member
  • **
  • Innlegg: 40
    • Vis profil
Sv: Har atter et zebra-batteri sagt takk for seg?
« Svar #4 på: mandag 12. november 2018, klokken 12:47 »
Ingen som har gode forslag? Etter gjennomlesning av stort sett hele dette forumet kom jeg over en gammel tråd (https://elbilforum.no/forum/index.php?topic=4890.90) der Orla Pedersen skriver:

"sys_highestErrCat, Highest error cattegory among active errors in battery system:

0 = No error
1 = Category statistic, (forsvinder af sig selv når fejlen forsvinder/rettes)
2 = Category notice, (skal resettes af zebra-monitor)
3 = Category delayed switch off, (skal resettes af zebra-monitor)
4 = Category switch off, (skal resettes af zebra-monitor)

Men,.....som jeg opdagede, så kan selv en category 3 fejl resette sig selv, og sker det ville jeg nok køle batteriet ned og få BMI'en undersøgt grundigt før næste "katastrofe" sætter ind."


sys_highestErrCat jeg får er 3, men den har så langt ikke resatt seg selv og zebra-monitor må jeg dessverre se langt etter her i Bergensområdet. Undersøkelse av BMI'en er heller ikke noen i området kan ta seg av etter hva jeg vet. Om noen har tips til hvordan jeg kan få resatt denne feilmeldingen tar jeg gjerne imot.

Orla Pedersen

  • Jr. Member
  • **
  • Innlegg: 64
    • Vis profil
Sv: Har atter et zebra-batteri sagt takk for seg?
« Svar #5 på: onsdag 14. november 2018, klokken 08:13 »
Det er svært at give råd, specielt når man har set konsekvensen, altså hvis det går galt. Jeg er overbevist om at zebra batterier er over deres levetid fordi byggekvaliteten ikke har været ok, og det helt starten.
Dit batteri eller BMI er defekt på en eller anden måde, ellers havde BMI'en ikke standset opvarmning og ladning.
Mvh
Orla Pedersen

Orla Pedersen

  • Jr. Member
  • **
  • Innlegg: 64
    • Vis profil
Sv: Har atter et zebra-batteri sagt takk for seg?
« Svar #6 på: onsdag 14. november 2018, klokken 08:29 »


0x264: PASEnable : 0 PilotSignalPresent: 1 OverTempIndication: 0 ElectricHzIndication: 0 MILIndication: 0 LowSOCIndication: 0 AuxBatLowIndication: 0 PowerLimitIndication: 0 BrakeWarningIndication: 0 ABSWarningIndication: 0 EconomyIndication: 0 OnPlugIndication: 0 ChargingIndication: 0 DriveEnableIndication: 0 ParkIndication: 0 ReverseIndication: 0 NeutralIndication: 0 DriveIndication: 0 PowerTrainGeneration: 0 PCUESPSoftware: 0 GearPosition: 0 PCUPTCReady: 0 ESPIndication: 0


Den er ny for mig, har ikke set 264 udlæst før. Har heller ikke set dokumenter beskrive 264.
Har nogen dokumentation for hvad der er hvad i denne datastreng? PRensel?
Vil gerne tilføje den til DuinoMite versionen, men skal vide hvilke bits der hvad. PRensel: do you have the dokumentation for the 264 datastring?
Mvh
Orla Pedersen

BauDemo

  • Hero Member
  • *****
  • Innlegg: 589
    • Vis profil
    • www.uppladdning.nu
Sv: Har atter et zebra-batteri sagt takk for seg?
« Svar #7 på: torsdag 15. november 2018, klokken 09:54 »
I thought 0x264 is a gear shifter message available on the cars with Gen2 PCU.
laddplats? -www.uppladdning.nu
nikometer? - www.evmonitor.info

Vidar_S

  • Jr. Member
  • **
  • Innlegg: 40
    • Vis profil
Sv: Har atter et zebra-batteri sagt takk for seg?
« Svar #8 på: torsdag 15. november 2018, klokken 14:30 »
Det er svært at give råd, specielt når man har set konsekvensen, altså hvis det går galt. Jeg er overbevist om at zebra batterier er over deres levetid fordi byggekvaliteten ikke har været ok, og det helt starten.
Dit batteri eller BMI er defekt på en eller anden måde, ellers havde BMI'en ikke standset opvarmning og ladning.

Det var noe sånt jeg fryktet ja. Bare håpet på at det var en mulighet for å se hvorvidt det er BMI som har feilet eller batteriet i seg selv er defekt. Det skal forresten sies at oppvarming går som den skal, men når temperatur er nådd avsluttes jobben ut over at batteriet holdes varmt.

Jeg har nå koblet fra lader og iverksatt "dvale" på batteriet. Tenkte la den stå to-tre uker så batteriet kjøler seg helt ned før jeg tester oppvarming/lading en siste gang. Om ikke det blir suksess går det nok mot salg av to stk delebiler.